PCI-Mandated Upgrade to TLS v1.2

What you need to know about upgrading from SSL and early TLS encryption protocols   Over the past few years, industry Security researchers identified vulnerabilities in the Secure Sockets Layer 3.0 (SSLv3.0), as well as early TLS versions of encryption protocol. In response, the Payment Card Industry (“PCI”) Council, as well as Visa and MasterCard, have issued a mandate that all merchants and service providers configure their systems in a manner to ensure secure connections […]

Read More...

PCI Compliance – TLS requirement

In October of last year, industry Security researchers identified vulnerability in the Secure Sockets Layer 3.0 (SSLv3.0) encryption protocol. In response, the Payment Card Industry (“PCI”) Council, as well as Visa and MasterCard, have issued a mandate that all merchants and service providers configure their systems in a manner to ensure secure connections between relevant systems by June 2016. In support of this PCI mandate, Sabre is requesting customers to take action by December 31, […]

Read More...